• Welcome to Virtual Transportation Center. Please login or sign up.
 

Advertisement

Recent Posts!

OMSI/OMSI 2 Trouble Shooting and Support Guidelines

Started by Dash5155, December 14, 2016, 06:42:58 pm

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Dash5155

Hello all,

Dash5155 is here with a set of guidelines to help you troubleshoot all your possible problems. In this thread we will first go over general troubleshooting/game maintenance. Then afterwards I will show you how to get the best support based on your problems.

Game Maintenance/Trouble Shooting
When having trouble with your game, here's a few steps you can take towards fixing your own issues.

Jumping Bus/Low Frame Rate/White Texture Game Crash

Unlike most games, OMSI 2 does not run well on its highest settings. So if you ever encounter low frame rate/jumping bus/no texture crash, try lowering your settings in game. Even if your settings work on other maps, these settings will most likely lag your game
  • Neighboring Tiles Despite what you think your computer can do, set this to 1. The more neighboring tiles you have to load, the more objects are in Memory. Since OMSI only uses 2gigs (or 4 with the 4GB patch), more dense maps will have trouble loading more than 6 tiles at a time (which the 1 neighboring tile does.
  • Load Whole Map at Start the larger the map, the more likely you are to run out of V-ram when you use this setting. While it prevents things like AI vehicles going off schedule or "teleporting" when they're out of view, there's no real benefit to using this setting. Best to turn it off completely
  • Reduced Multithreading I won't even say anything on this. Just turn it off unless your game is actually unstable (as in it crashes upon startup even on the default Berlin map. All it does is make your computer only use 1 core to process the game instead of 2 or 4 or however many you actually have. It's just asking for lag. For some reason OMSI automatically enables this with each crash, even if that setting wasn't the reason for the crash.
  • View Distance Since you should have 1 neighboring tile, there's no reason to have this setting above 500 since each tile is 300 meters and you won't be able to see what's on the next tile until you approach it anyway, so if your view distance is above 500, it's just going to try to load objects that you can't see, thus un-needed lag
  • Max Frame Rate Just triple check to make sure this is above 10. When you first install OMSI this setting is always at 10, and I'm not sure why. Set it to like 60 or 200 even if your computer can't handle such high rates.
  • Sound Settings Turn off AI sounds, Reverb effects, and Doppler effects. Also set "max sound count" to 200. Don't question this, your frame rate will skyrocket if you turn these off.
  • Apply a 4GB Patch Click here to download a patching program which converts 32bit applications to utilize more than 2GB of Vram. When you download this program, open the .exe and direct it to your OMSI.exe (obviously, it's in the root folder of your OMSI 2 install) and wait until it says patch successful. Once you do that, the game should no longer crash when using more than 2GB of Vram. HOWEVER. If your settings are too high, the lighting effects in OMSI will be disabled.

If you have all these settings set the way I say, and you still get a low overall frame rate, it's your computer. Lower some other settings to get frame rate increases.

How do you get to your OMSI 2 default files?

It's a process steam calls "verifying the game cache"

If you already know what this is, you don't have to read any further. However if you do not, I will explain how to do it.

Step one: Make sure steam is in "Online mode."  This will not work in offline mode as steam is required to access the steam servers in order to retrieve your files.

Step two: go into the steam library and right click on "OMSI 2"

Step three: a drop down menu will come up. click on "properties"

Step four: a window will pop up. In that window click on the "local files tab



Step five, final step: click on "verify integrity of game cache" and then follow the prompts to finish that process.

Aaaaand you're done. You have just restored all your OMSI 2 default files. You didn't delete any files, however, you may have to re-adjust your settings and game configurations.

Blue Sky Glitch/Missing Tile Glitch in Maps

This means one or two things, but both can be fixed the same. Either you're missing objects or your object pack is out of date (namely Addon_GCW).

Fixes: Download OMSI Map Tools and run it on the map that gives you that glitch. If it shows that you are missing objects, run a google search on the folder name to see if you you can find it. If not, ask on the forums if someone has that particular file/addon. If it returns that you are not missing any objects, check to see if the map utilizes "Addon_GCW" If it does, download the latest version of here and see if it helps

Searching Support Sites/Google for your problem

Chances are you may find the solution to your posted elsewhere, which may help you find your solution quicker instead of waiting for someone to figure out what's going on and trying to fix it. Especially when it comes to general problems like jumping bus. This is a general rule you should follow for a lot of problems, not just OMSI. I STRONGLY recommend browsing the support section of the forums, or typing your issue into a search instead of just giving up all hope and asking for help. Be independent.

Posting a Support Thread
Now that we covered all the troubleshooting, I will now cover how to post a proper support thread. Please don't post your issues in a private chat or on social media because when posting a support thread, you will not only help yourself but also many others if they have your same issue. You'll be helping more people when you make your issue public than when you keep it on an un-searchable database like Facebook.

Be specific as possible

If you want to be helped, please make sure you include as many details about your problem as possible, including what you have done before and after installation. For example, I can't help you if you say "my map don't work, fix it." However if you say "I attempted to install the Liberty map, and I have found and installed all the respective dependencies in their proper folders. However, upon starting the map, when it got to the point of 'Loading environmental traffic' my game crashed with an error message and a code number I don't quite remember" I may be able to help, especially if I know exactly what happened and can possible re-create the issue myself. However I may not always be able to do just that, so this next part will help that

Copy and Paste the contents of your logfile.txt in the post

What's a Log file? It's a file located in the same folder as your OMSI 2.exe that shows everything that happened in your most recent OMSI session. Including when tiles refresh, when the game is unable to load textures, and collisions. It's a rather detailed and complex thing. Simply open up this file in notepad, copy the contents, and paste it in your thread (preferrably in spoiler tags) so that we can actually see what's going on in game.

This is where you can find this file:




The ideal support post looks like this:

Quote from: Dash5155Hi, I went into OMSI editor to adjust the schedule for a new route, and I had no problems. I have done everything properly. However the game has crashed.

This is the contents of my logfile:
Spoiler: ShowHide

====================
    Start logging
====================

Date:    11/16/2016
Time:    6:05:39 PM
Version: 2.3.004

Other Logfile junk

What could have triggered the crash

With this post, we can see what the user did, what happened when the game crashed, and understand what the user needs done. Anyway thanks for reading guys, and I hope you acknowledge this post for future problems. Have a great day.

43 Guests, 4 Users
     

Advertisement

TinyPortal © 2005-2018